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Exam A 

QUESTION 1 

Which one of the following contains data types stored as summary data by default? 

A. All data types are stored in the summary buffer 

B. Rich text, file attachments, embedded OLE objects 

C. Text, text lists, rich text 

D. Text, number, date/time, reader names 

Correct Answer: D 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 2 Mike is upgrading a Web application to use a different CSS stylesheet for different 

types of browsers. 

Which of the following @functions should he used to determine which Web browser the user is accessing his application with? 

A. @BrowserType 

B. @ClientInfo 

C. @BrowserInfo 

D. @Browser 

Correct Answer: C 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 3 Jarrod wrote an agent that begins with the following 

LotusScript code: 

Dim session As New NotesSession Dim db As NotesDatabase Dim view As NotesView Dim doc As NotesDocument Set db = session.CurrentDatabase Set view = db.GetView( "By Category" ) Set doc = view.GetDocumentByKey( 

"kitten" ) 

When the agent runs, which document will be referenced by the "doc" variable? 

A. If the database is full-text indexed, the first document in the By Category view that contains the word “kitten” in any field. If the database is not full-text indexed, the “doc” variable will be empty. B. 

The first document in the By Category view that has a value of “kitten” in the first sorted column 

C. The first document in the By Category view that contains the word “kitten” in any field 

D. The first document in the By Category view that has any value in the column with an alias of “kitten” 

Correct Answer: B 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 4 

Menno has hidden the design of a database and finds out later that most of the design elements have the "prohibit design refresh or replace to modify this element" flag set. 

How can he undo this? 
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A. He cannot; hidden design is hidden forever. 

B. He can simply replace the design with a blank template, and then replace again with the corrected template. 

C. He needs to go into the design and untag each and every element manually, and then simply replace the design with the updated (new) template once more to update with the last changed. 

D. He needs to create an agent that uses the LotusScript Design classes to remove every design element in the database , and afterward use the corrected template to replace the whole design once more. 

Correct Answer: D 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 5 

Clifford has a Readers field in his Expense Report form. Who will be able to see the document once he saves it in the application? 

A. Only those people listed in the Readers field. 

B. Anyone listed as a Reader or above in the Access Control List who is also listed in the Readers field. 

C. Anyone listed as a Reader or above in the Access Control List. 

D. Only those people listed in the Execution List or the Access Control List. 

Correct Answer: B 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 6 

A Text field on a Form is set to "Allow multiple values". Jan is designing the form, and wants to set the default value of the field to a text list of "Apple", "Orange", and "Grape". 

What Default field value formula should she use? 

A. “Apple”, “Orange”, “Grape” 

B. “Apple”: “Orange”: “Grape” 

C. “Apple” + “Orange” + “Grape” 

D. @TextToList(“Apple”; “Orange”; “Grape”) 

Correct Answer: B 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 7 A button on a Notes document has the following 

LotusScript code: 

Dim workspace As New NotesUIWorkspace Dim uidoc As NotesUIDocument Set uidoc = workspace.CurrentDocument Call uidoc.GotoField("Status") Print "Approved" Where 

will the word "Approved" appear after the button is clicked? 

A. In the server’s log.nsf file 

B. On the status bar 

C. In the “Status” field of the current document 

D. In a messagebox 

Correct Answer: B 

Section: (none) 
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Explanation 

Explanation/Reference: 

QUESTION 8 Kelsey has a LotusScript agent that uses a dialog box to gather information 

from the user. 

How should he modify this agent for use on the Web? 

A. Use a Domino form to capture the information, modify the LotusScript agent to process these fields, and call the agent from the WebQuerySave event. 

B. Use the LotusScript Evaluate function to call the @WebDialogBox finction. 

C. Rewrite the agent as a JavaScript agent. Use window.prompt to capture the information from the user. 

D. Change the code to @Functions and use the @WebDialogBox function. 

Correct Answer: A 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 9 Maria wants to populate a list with the values "Alpha", "Beta", 

and "Gamma". 

What syntax should she use in the formula? 

A. “Alpha”, “Beta”, “Gamma” 

B. “Alpha”; “Beta”; “Gamma” 

C. “Alpha”: “Beta”: “Gamma” 

D. “Alpha” & “Beta” & “Gamma” 

Correct Answer: C 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 10 

Erica is writing a formula to determine the number of elements in a list. She wants to ensure that a nonzero positive value is returned, even if the value her @Function is evaluating turns out to be a null string. 

Which one of the following can she do to accomplish this? 

A. Use a default formula of 1 

B. Use @Elements and add 1 to the total 

C. Use the @Count function instead of @Elements 

D. Use @Elements([PosInteger]) to ensure that the desired format is returned 

Correct Answer: C 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 11 

Jamie needs to add a RestrictAccess field on a form in the Purchasing application. Only users with the [Admin] role should be able to see this field. 
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How should she write the hide/when formula to hide this field? 

A. @Elements(“[Admin]”;@UserRoles) 

B. @IsNotMember(“[Admin]”;@UserRoles) 

C. @IsContained(“[Admin];@UserRoles) 

D. @Show(“[Admin]”;@UserRoles) 

Correct Answer: B 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 12 Magdalena wants to allow the users of her application to rearrange and change the settings for some views (including private views), to allow them to optimize their experience in 

the application. 

How does she best do this? 

A. Select the “Create Personal view/folders” option in the ACL, Select the “Allow customizations” option in the Database properties and the “Default design for new folders and views” option in the View properties. 

B. Unselect the “Create Personal view/folders” option in the ACL. Select the “Allow customizations” and “Resizable” options in the View properties. 

C. Select the “Allow customizations” and “Default design for new folders and views” options in the View properties. 

D. Select the “Allow customizations” option in the View properties and select the “Save User settings” option in the Column properties. 

Correct Answer: C 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 13 What function does the Formula 

type field perform? 

A. It allows documents of interest to be served via subscriptions in the Headlines database. 

B. It allows multiple values in a field to be validated against a defined @Formula statement. 

C. It allows documents to precompute specific values based on user input. 

D. It allows @Formula statements to be entered in a document without executing. 

Correct Answer: A 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 14 

Sam wants to display a column only if the current user is associated with the Manager role. Otherwise, the column should be hidden. 

Which one of the following will allow him to do this? 

A. Use @IsNotMember(“[Manager]”; @UserRoles) in the hide-when view column formula. 

B. Use @IsNotMember(“[Manager]”; @UserRoles) in the hide-when field formula. 

C. Use @IsMember(“[Manager]”; @UserRoles) in the hide-when view column formula. 

D. Use @IsMember(“[Manager]”; @UserRoles) in the hide-when field formula. 

Correct Answer: A 

Section: (none) 
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Explanation 

Explanation/Reference: 

QUESTION 15 

Hermes wants to program a button to allow a user to modify the Status field to a value of "Approved" on the document that they are currently editing in the Lotus Notes client. 

Which of the following fragments of LotusScript code will do that? 

A. Dim workspace As New NotesUIWorkspace Dim uidoc As NotesUIDocument Set uidoc = workspace.CurrentDocument Call uidoc.FieldSetText(“Status”, “Approved”) 

B. Dim workspace As New NotesUIWorkspace Dim uidoc As NotesUIDocument Set uidoc = workspace.CurrentDocument uidoc.Statuc = “Approved” 

C. Dim workspace As New NotesUIWorkspace Dim field As NotesUIField Set field = workspace.GetField(“Status”) Call field.SetText( “Approved” )D. Dim workspace As New NotesUIWorkspace Dim doc As NotesDocument Set doc = 

workspace.CurrentDocument doc.Status = “Approved” 

Correct Answer: A 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 16 Roger wants a JavaScript function to execute in the onLoad 

event for a form. 

What must he select to have it run for both Web and Lotus Notes clients? 

A. Select the form property “Render JavaScript in Notes and Web.” 

B. Select “Available Everywhere” in the onLoad event. 

C. Paste the code into the Lotus Notes onLoad event and the Web onLoad event. 

D. Select “Common JavaScript” in the onLoad event. 

Correct Answer: D 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 17 

Mahesh must ensure that only users with the DbAdmin role can edit the Price field on the Product form. The other fields on the form are editable by all users. 

How can Mahesh restrict who can edit the Price field? 

A. From the Security tab of the Field Properties, select the [DbAdmin] role in the Edit Enabled option. 

B. Place the Price field in a computed subform. 

C. Add an Input Enabled formula to the Price field. Use the formula: @IsMember[“DbAdmin]”; @UserRoles) 

D. Add a computed Authors field to the Product form. For the field value, specify @If(@ThisName=”Price”; “[DbAdmin]”; “”) 

Correct Answer: C 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 18 

Jim is designing a new application that will be deployed to multiple sites using database replicas. 
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Which one of the following will he be able to replicate? 

A. Database launch properties 

B. Database file names 

C. View indexes 

D. Full Text indexes 

Correct Answer: A 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 19 

Therese wants to write some LotusScript code that steps through every document in a view and displays the "Title" field. She currently has the following code written: 

Dim session As New NotesSession Dim db As NotesDatabase Dim view As NotesView Dim doc As NotesDocument Set db = session.CurrentDatabase Set view = db.GetView( "By Category") Set doc = view.GetFirstDocument Do Until (doc 

Is Nothing) Print doc.Title(0) '** MISSING CODE ** Loop 

What does she need to add on the ** MISSING CODE ** line to make the code work properly? 

A. Set doc = view.GetNextDocument() 

B. Set doc = view.GetNextDocument(doc) 

C. Nothing. The code will work properly as-is. 

D. Call view.GetNextDocument() 

Correct Answer: B 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 20 

Erin has created a categorized view in her Human Resources database that supports unread marks. When users access the view and try to expand some categories, no documents appear even though the users see unread marks beside the 

category. 

Which one of the following could be the problem? 

A. The documents include Reader names fields. 

B. The database needs to be replicated. 

C. The missing documents in the category have been soft deleted from the database. 

D. The view has an old index and must be reindexed. 

Correct Answer: A 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 21 

Danielle is updating the "companyName" field on all documents in a view. The field may include varying text, but the field always includes the text "Blue Corporation". For example, one of the documents has "Blue Corporation, a whollyowned 

subsidiary of GigantaCorp" as the contents of the companyName field. 

What formula can Danielle include in her agent to change the "Blue Corporation" text in each companyName field to now be "Green Enterprises". 
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A. FIELD companyName := @Set(@Middle(companyName; “Blue Corporation”); “Green Enterprises”) 

B. FIELD companyName := @SetString(companyName; “Blue Corporation”; “Green Enterprises”) 

C. FIELD companyName := @Replace(companyName; “Blue Corporation”; “Green Enterprises”) 

D. FIELD companyName := @ReplaceSubstring(companyName; “Blue Corporation”; “Green Enterprises”); 

Correct Answer: D 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 22 Gwen would like to create an "ATTENTION" line that will toggle on and 

off each second. 

What can Gwen do to provide the blinking text? 

A. In the desired location on the page, enter “ATTENTION”, and set the desired font properties. From the Paragraph Styles tab of the text Properties, select Blink. The default interval is 1000 milliseconds. 

B. Open the page in Domino Designer and create a two-row Table. Type “ATTENTION” in one of the table rows, setting the desired font properties . Click the Programmed table button in the Table Type section. On the Table 
Programmingtab, click “Animated” for the mode, and enter 1000 for the Frequency option. 

C. In the desired location on the page, enter the following: <blink ms=”1000”>ATTENTION</blink> Highlight the “ATTENTION” text and set the desired font properties. From the menu bar, select Text > Pass-Thru HTML. 

D. Open the page in Domino Designer and create a two-row Table. Type “ATTENTION” in one of the table rows, setting the desired font properties. Click the Animated table button in the Table Type section. On the Table Rows tab of 

theTable properties, enter “1000” after “Switch row every”. 

Correct Answer: D 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 23 

Greg has created a form with several fields that get their data from an external relational database system based on a key field. DECS is installed. 

Which one of the following must he have done to achieve this functionality? 

A. Created a data connection resource 

B. Manually imported the data from the relational database 

C. Created an embedded RDBMS link 

D. Created an ODBC connection resource 

Correct Answer: A 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 24 Jacob is working in Designer and is viewing a list of all the design elements in 

his application. 

What part of Designer is he looking at? 

A. Controls Palette 

B. Outline View 

C. Editor 

D. Application Navigator 
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Correct Answer: D 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 25 

Ian has written a LotusScript agent to record some statistics when a browser user submits a document. 

What LotusScript NotesSession property allows Ian to get a copy of the submitted Lotus Domino document before it is saved? 

A. CurrentDocument 

B. Document 

C. DocumentContextD. DominoDocument 

Correct Answer: C 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 26 Bram needs to change a large number of documents in an existing application and add the three fields from the Document NewDoc to each existing document. He has created a document collection of the documents 

to be changed. 

How can he best achieve this? 

A. Call Collection.Stampall (NewDoc) 

B. Call Collection.Stampall (“location” : “HomeID” : “HelpNr” ; “NY” : “123” : “80012345678” ) 

C. Call Collection.StampallMulti (“location” : “HomeID” : “HelpNr” ; “NY” : “123” : “80012345678” )D. Call Collection.StampAll Multi(NewDoc) 

Correct Answer: D 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 27 

In the Video form, the OrderDate field (which shows when the video can be ordered) is calculated based on the Date field (which displays the release date). The order date is 30 days prior to the release date. 

Which one of the following formulas will calculate the OrderDate value? 

A. @If(Date != “”;Date – 30;@Failure(There is no current release date”)) 

B. @Number(date) – 30 

C. @Adjust(Date;0;0;30;0;0;0) 

D. @Adjust(Date;0;0-30;0;0;0) 

Correct Answer: D 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 28 

Billy wrote some JavaScript code for validating user-entered field values on his Web forms. 
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What should he do to make that code available to all forms in his application? 

A. Create a shared field called $$JSHeader with the JavaScript code and include the shared field in every form. 

B. Create a page named validate and embed it into each form. 

C. Create a JavaScript library and insert it into the JavaScript header event on each form. 

D. Attach a JavaScript file to a page and embed the page into each form. 

Correct Answer: C 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 29 Cindy wants to edit her style sheet resource using a 

third-party tool. 

Which one of the following should Cindy do? 

A. From the Resources>Style Sheets view, select the style sheet and choose Open With, then identify her preferred editor. 

B. From the Resources>Style Sheets view, select the style sheet and choose Open With>External Editor, then identify her preferred editor. 

C. From the Resources>Style Sheets view, select the style sheet and choose Open With>Thirdparty Tool, then identify her preferred editor. 

D. From the Resources>Style Sheets view, select the style sheet and choose Export to save the style sheet to the file system, the open it in her preferred editor. After making her changes, she will need to choose Sync to bring the 

changesinto the application. 

Correct Answer: B 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 30 

Geoff has recently upgraded to Notes Domino 8.5 and has been exploring the various options within Domino Designer in Eclipse (DDE). 

What can Geoff do to see his Applications within the Applications Navigator of DDE? 

A. Right-click on an Application icon from the Notes workspace and select Open in Designer. The Applications Navigator always opens in the left pane, just as in Domino Designer 8.0 and earlier releases. Other views, such as Outline canbe 

moved or closed if desired. 

B. Right-click on an Application icon from the Notes workspace and select Open in Designer. If the Applications Navigator is not visible, select Window > Show Hidden Views > Applications. Other views, such as Outline, can also be movedor 

closed. 

C. Right-click on an Application icon from the Notes workspace and select Open in Designer. The Applications Navigator always opens, but it can be repositioned. Other views, such as Outline can be moved or closed if desired. 

D. Right-click on an Application icon from the Notes workspace and select Open in Designer. If the Applications Navigator is not visible, select Window > Show Eclipse Views > Applications. Other views, such as Outline, can also be movedor 

closed. 

Correct Answer: D 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 31 Which of the following is a benefit of HTML rendering in 

lotus Domino? 

A. Allows writing of HTML for different clients without recoding 

B. Allows saving HTML with errors 

C. Prevents saving XML with errors 
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D. Allows easy conversion of XML to HTML 

Correct Answer: A 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 32 

Linda would like to build a notification dialog box for the user of the Update Checkout agent. When the agent is done, it should tell the user how many video documents were updated. 

What is the command she should use for this feature? 

A. Print “The agent processed” & i & “documents”, MB_OK + MB_ICONINFORMATION, “Agent Completed” 

B. Print “The agent processed” & i & “documents”, MB_OK , “Agent Completed” 

C. Messagebox “The agent processed” & I & “documents”, MB_OK, “Agent Completed” 

D. Messagebox “Agent Completed, MB_OK : MB_ICONINFORMATION, “The agent processed” & I & “documents” 

Correct Answer: C 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 33 Janet uses Domino Designer's Dynamic Help feature to 

clarify something. 

What kind of help will she get? 

A. A context-sensitive Help View that constantly updates a list of possible relevant topics based on what she’s doing. 

B. An animated, talking icon that offers to assist her. 

C. A personalized search interface that remembers all of her previous searches and their results. 

D. A wizard that follows a support tree to narrow down the answer to her question. 

Correct Answer: A 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 34 

The @Formula statements that Gustavo is entering for validation formulas on his Form are in a smaller font than he would prefer. 

How can Gustavo adjust the font that he sees while he is coding within Domino Designer? 

A. Select Application Properties from the Application Navigator. Select Fonts from the Script area of Options. Select the desired font, size, and color. 

B. Create a style sheet with a class named “DesignerScript”, set the desired font attributes and import the CSS. Right-click on the Style Sheet and select Designer Default. 

C. Select File > Preferences > Domino Designer. Locate the Appearance section. Select Script > Fonts. Select the desired font, size, and color. 

D. Right-click within the Programmer’s Pane to open the Programmer’s Pane Properties. Select the desired font, size, and color. 

Correct Answer: D 

Section: (none) 

Explanation 

Explanation/Reference: 
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QUESTION 35 

Julie wants to have a view action display in a custom pop-up menu when the right mouse button is clicked. 

How can she do this? 

A. Set the Action bar to “Include in right mouse button menu”. 

B. Set the Action button to “Include in right mouse button menu”. 

C. Set the database property to “Include actions in right mouse button menu”. 

D. Set the view property to “Include actions in right mouse button menu”. 

Correct Answer: B 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 36 

Barb is the Lead Developer for the Sales application and the Travel application. Each application is comprised of multiple databases. Within the Applications Navigator, Barb would like to be able to list the databases of the Sales application 

together, and - separate from the Sales application - list the databases of the Travel application together. 

How can she do this? 

A. Edit the Application Properties of each database that comprises the Sales Application. On the Design tab, specify “Sales” for the “Working Set” option. Repeat for each database of the Sales application. Perform a similar procedure forthe 
Travel application. 

B. Click the Folders icon within the Application Navigator. Select the option to Create a new Working Set. Name the Working Set “Sales” and select the databases that comprise the Sales application. Perform a similar procedure for thetravel 
application. 

C. For each application, create a subfolder under the Data folder. Move each of databases to the appropriate subfolder. Drag each folder onto the Applications Navigator. 

D. From Domino Designer Select Create > Working Set. Specify “Sales” for the name. From the Application Properties of each database of the Sales application, select “sales” from the Working Set drop-down. Perform a similar procedurefor 

the travel application. 

Correct Answer: B 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 37 Cindy locked a design element and left on vacation. The design element has 

to be changed. 

Who can change it? 

A. Anyone with Editor access or higher 

B. Only those with Manager access 

C. Anyone with Designer access or higher 

D. Only Cindy 

Correct Answer: B 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 38 

Nathan created a secret key named Salary, and he has enabled encryption for three fields on the SalaryHistory form. He wants to ensure that all three of these fields are always encrypted whenever a SalaryHistory document is saved. 

What should Nathan do next? 
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A. From the Field properties for each of the three fields, select Salary under “Encryption key(s)”. Select the name of each of the individuals needing access to the field and save the form. 

B. From the basics tab of the database properties, click encryption Settings. Select “Automatic encryption”. Mail the secret key to the individuals who need access to the encrypted fields. 

C. From the Security tab of the Form properties, select salary under “default encryption keys”. Save the form, and mail the secret key to the individuals who need access to the encrypted fields. 

D. From the Security tab of the Form properties, select “Default encryption”. Mail the secret key to a Notes administrator and request the key to be merged into the certificate on the person document of each user needing access to 

theencrypted fields. 

Correct Answer: C 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 39 

When creating your own classes, how can you integrate an existing LotusScript class like "NotesDocument"? 

A. Class MyOwnClass As NotesDocument 

… 

End Class 

B. Class MyOwnClassInclude NotesDocument 

… 

End Class 

C. Class MyOwnClass 

MyDocument As NotesDocument 

… 

End Class 

D. Class MyOwnClass includes NotesDocument 

… 

End Class 

Correct Answer: C 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 40 

The XML representation of a Domino database, including its design and data, is known as which of the following? 

A. DXML 

B. DXL 

C. DominoXL 

D. XMLD 

Correct Answer: B 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 41 

Norita has a form with a field that allows the user to choose the background color of a particular document. 

How has she set up the field to accomplish this? 

A. It is a Dialog List field that allows the user to choose a color to use. 
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B. it is a Color field that allows the user to choose a color from the palette. 

C. It is a Rich Text field that allows the user to highlight text and select a font color. 

D. It is a Text field that allows the user to type the name of a color to use. 

Correct Answer: B 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 42 Cheng wants to write a view selection statement to include documents created with the Review form and 

any responses. 

Which one of the following statements should Cheng write? 

A. SELECT Form = “Review”; SELECT @Responses 

B. SELECT Form = “Review”; SELECT @AllResponses 

C. SELECT Form = “Review” & @AllDescendants 

D. SELECT Form = “Review” | @AllDescendants 

Correct Answer: D 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 43 Mac is planning a Change Control application that will be used by thousands of staff located in 10 

different countries. 

What is one thing Mac can do to help optimize the performance of the application for his users? 

A. Use File > Replication > New Replica to create a replica of the application on a server in each country, and have users access the application from a local server. 

B. On the Advanced tab of Database properties, enable “Don’t support specialized response hierarchy” and disable “Allow simple search” 

C. Use File > Application > new Cope to create a copy of the application on a server in each country, and have users access the application from a local server.D. On the Advanced tab of Database properties, enable ‘Support specialized 

response hierarchy” and enable “Allow simple search” 

Correct Answer: A 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 44 

Nora is writing an agent to update certain documents. She needs to ensure that the only records processed are records in which the Model field has a value of "Compact". 

Which one of the following statements will Nora include in her agent, and where will the line be placed? 

A. SELECT Model = “Compact”; 

Last line in the agent 

B. @If (Model = “Compact”;@Success;@Failure); 

First line in the agent 

C. SELECT Model = “Compact”; 

First line in the agent 

D. @If (Model = “Compact”;@Success;@Failure);Last line in the agent 
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Correct Answer: C 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 45 Minh supports the Change Control database. He has been asked if he can change the "by Month" Calendar view so that the days that are outside of the selected month are displayed with a light gray background and 

dark gray text. 

What can Minh do to address this request? 

A. Create a hidden column immediately before the StartDate column in the view. Select the “Use value as color” option. Code a formula to evaluate to one set of RGB values for Background and Text if the date is in the current month, anda 

different set of RGB values for dates outside the current month. 

B. Modify the “Date Area” option on the View properties Styles tab. Select a light gray background and set the Text color to dark gray. Modify the colors for background and text in the Current option area to differentiate the gray scheme. 

C. Modify the “Monthly” option on the View properties Styles tab. Select a light gray color for the “Not current” color, and select a dark gray color for the Text color. 

D. This request cannot be met completely, but Minh can set the Body Background color for the entire view on the View properties Styles tab. He can then control the Text colors by creating a hidden column set to “Use value as color”, andby 

coding a column value formula to evaluate to RGB values. 

Correct Answer: C 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 46 Daniel is designing a Suggestions application and wants to minimize 

replication conflicts. 

Which one of the following will accomplish this? 

A. Assign users Author access to the database. Create a form of type Document and name the form “Suggestion”. Create a form of type Comment and name the form “Comments”. Use Readers fields on both forms. 

B. Assign users Author access to the database. Create a form of type Document and name the form “Suggestion”. Create a form of type Response and name the form “Comments”. Use Readers fields on both forms. 

C. Assign users Editor access to the database. Create a form of type Document and name the form “Suggestion”. Create a form of type Comment and name the form “Comments”. Use Authors fields on both forms. 

D. Assign users Author access to the database. Create a form of type Document and name the form “Suggestion”. Create a form of type Response and name the form “Comments”. Use Authors fields on both forms. 

Correct Answer: D 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 47 

Marcello wants to create a custom startup page for his customer database, using different buttons and values from profile and normal documents. 

How can he achieve this? 

A. Create an outline with calculated entries, and display this directly through a frameset. 

B. Create a page with calculated text and actions, and display this using a frameset. Create a frameset, and display that page with dynamic text. 

C. Create a view with custom actions that calculate what actions the user might want to take. 

D. Create a form and use action buttons, only calculated for display fields and computed text to display all available options to this specific user. Set the database properties to start with a doclink in the about database document to 

anydocument created with this form. 

Correct Answer: D 

Section: (none) 

Explanation 
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Explanation/Reference: 

QUESTION 48 

Tresa's users sometimes forward SalesOrder documents to coworkers if they have a question about the order. When the recipient of the forwarded document opens the mail message, they see an error message before the document opens. 

Tresa has determined that a hot-spot button on the SalesOrder form references code from the SalesOrder form. 

How can Tresa allow her users to forward documents without this button being forwarded? 

A. Open the SalesOrder form. From the Advanced tab of the Form properties, select “Send as RT Item” from the “On Send” options. 

B. Open the SalesOrder form. From the Security tab of the Form properties, select “Disable printing/forwarding/copying to clipboard”. 

C. Open the SalesOrder form and click on the hot-spot button. Add a hide formuls of “@IsDocBeingForwarded”. 

D. Open the SalesOrder form and click on the hot-spot button. Select “Copied to the clipboard” from the Hide tab of the Button properties. 

Correct Answer: D 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 49 Malik needs to find all the design elements that reference a particular field 

in his database. 

How could he accomplish this? 

A. File – Application – Analyze Design 

B. Edit – Find Next 

C. Edit – Find/Replace 

D. File – Application – Design Synopsis 

Correct Answer: D 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 50 

When Nora creates a new document in the Suggestion application, a number of the fields have text already displayed. But when she tabs or clicks into the field, the text disappears. 

What design feature has been used to create this behavior? 

A. Default Value in the Form Properties dialog box 

B. Help Description in the Field Properties dialog box 

C. Field Hint in the Field Properties dialog box 

D. Field Assistance in the Field Properties dialog box 

Correct Answer: C 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 51 

Peter is working on the Sales Discussions application. He is building a new view that should display all main documents, and also all documents that have been submitted in response to the main documents or in response to other comments. 
Peter is trying to determine which @Function refers to all "Response" and "Response to Response" documents of parent documents. 
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Which Formula will meet Peter needs? 

A. @AllResponses 

B. @AllChildren 

C. @AllDescendants 

D. @Responses 

Correct Answer: C 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 52 Management has asked Bob to post an introductory Welcome page when Notes users first open the 

Video application. 

In which one of the following places should Bob put the Welcome message? 

A. In the application Using Document 

B. In a document named $Welcome 

C. In the application About Document 

D. In the first Page in the application design 

Correct Answer: C 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 53 Bernhard is having trouble with an application, and he wants to allow users to save their work while 

they are editing. 

What does he need to do? 

A. Select the “Autosave document” in the document properties 

B. Select the @Allow Auto Save” in the document properties 

C. Nothing; Notes autosaves any document in Edit mode in Notes 8.5 by default 

D. Create a timerevent, and save the document periodically through UiDocument.Save 

Correct Answer: B 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 54 

Adam is trying to update the design of a production database with changes from a design template that was tested on a special environment during development. 

What does he need to know before he uses the design on the production database? 

A. Nothing, design changes from development can be put on the production system without additional research. 

B. He needs to resign only the documents with production server id; all design elements don’t need to be designed. 

C. He needs to put a replica of the production database on the test environment, change the design there, and replicate it back. 

D. He needs to know if the production database is signed with a special id, to prevent ECL warnings for the users. 
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Correct Answer: D 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 55 

The graphic designer at Roshni's company has developed a graphic theme to be applied to all of the company's HR databases. Roshni has created a new image resource using the twistie.gif provided to her, but the categories in the views do 

not appear the way the graphic designer had described. 

What could be the problem? 

A. Roshni was given a single 16x16 pixel image of the image that should display for a collapsed category. The image resource needs to be a 33x16 pixel image a 16x16 gif of the image for collapsed categories, followed by a one-pixelvertical 

spacer, and a 16x16 gif of the image for expanded categories. 

B. Roshni received two 16x16 pixel images – one for expand and one for collapse, but she has updated the Column properties. She now needs to designate a 16x16 resource image for the “Expand twistie” and a 16x16 resource image forthe 

“Collapse twistie” options on the Column Properties box. 

C. Roshni received a single 33x16 pixel image, containing a 16x16 gif of the image for collapsed categories, followed by a one-pixel vertical spacer, and a 16x16 gif of the image for expanded categories. She created the image resource,but 

she needs to select the “Animated gif” option. 

D. Roshni received two 16x16 pixel images – one for expand and one foe collapse. But she imported the image resources as “open.gif” and “close.gif”. The images must be named “expanded.gif” and “collapse.gif”. 

Correct Answer: A 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 56 

Cheryle would like to have access to her mail file while she is traveling and disconnected from the network. Once she arrives at her destination, she wants to connect to the network and synchronize her mail file updates with the server version 

of her mail file. 

How can she accomplish this? 

A. Create a local replica of her mail file. 

B. Create a local synchronized copy of her mail life. 

C. Create a local copy of her mail file. 

D. Create a local mirror copy of her mail file. 

Correct Answer: A 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 57 

When Eduardo tried to save a document, he got the following error message: Incorrect data type for operator or @Function: Text Expected. 

Which one of the following did he most likely do to cause this to happen? 

A. He neglected to place a formula in a translation event. 

B. He entered text in a number field. 

C. He combined a text field and a time field in a formula. 

D. He neglected to place a formula in a validation event. 

Correct Answer: C 
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Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 58 

Herman has created a new design for his Video application. He would like to post the design to the server and make it available so other applications can automatically inherit the design changes when the DESIGN server tasks runs. 

Which one of the following should Herman to do make the new design available on the development server? 

A. Copy the application to the development server, name it “newvideo.ntf”, and select “Allow inheritance” in the application Design properties. 

B. Copy the application to the development server, name it “newvideo.ntf”, and select “Inherit design from master template”, and give it a template name in the application Design properties. 

C. Copy the application to the development server, name it “newvideo.ntf”, and select “Database file is a master template”, and give it a template name in the application Design properties. 

D. Copy the application to the development server, name it “newvideo.ntf”, and select “Update on DESIGN task” in the application Design properties. 

Correct Answer: C 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 59 

Kelly supports the Inventory application. This application is accessed by staff in India, the UK, Brazil, and the USA. For reasons of performance and contingency planning, the office in each country has its own server. Kelly needs the Inventory 

application to reside on each of these servers, and she needs to ensure that the application data and design is kept in sync among all of these locations. 

How can Kelly meet this requirement? 

A. Select the Inventory application. For each server, create a replica of the application by selecting File > Replication > new replica, and specify the target Server. 

B. Select the Inventory application. For each server, create a copy of the application by selecting File > Application > New Cope. Specify the target Server, and select the Synchronize option. 

C. Select the Inventory application. For each server, create a mirror of the application by selecting File > Application > New Mirror, and specify the target Server. 

D. Select the Inventory application. For each server, create a synchronized copy of the application by selecting File > Synchronization > New Copy. 

Correct Answer: A 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 60 Richard's form includes a field that causes a document to be mailed when the 

document is saved. 

Which of the following is the reserved field name that Richard assigned to the field? 

A. SaveOptions 

B. ForceMail 

C. MailSend 

D. MailOptions 

Correct Answer: D 

Section: (none) 

Explanation 

Explanation/Reference: 
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QUESTION 61 

Muriel has created a view that shows the current year's reported sales in the Sales Tracking application. She would like to give her end users the ability to sort on the customer, region, and sales manager columns. 

How would she accomplish this? 

A. Set the ‘Allow custom sorting” option for the view. 

B. Set each column’s Sort option to Descending. 

C. Set the ‘Click on column header to sort” value to Custom for all three columns. 

D. Set the ‘Click om column header to sort” value to Both for all three columns. 

Correct Answer: D 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 62 

Robert does not want Authors in the Video database's ACL to be able to edit certain fields in documents they created. 

Which one of the following can he do to accomplish this? 

A. Use an Authors field on the form to prevent access to existing documents. 

B. Set field security options to: Must have at least editor access to use. 

C. Use a Readers field on the form to prevent access to existing documents. 

D. create a standard section on the form and put the restricted fields in the section. 

Correct Answer: B 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 63 Luis needs to add a field to a form that will allow him to enter up to 500 

kilobytes of data. 

What type of field should he use for this requirement? 

A. Text 

B. Extended Text 

C. Rich Text 

D. Expanded Text 

Correct Answer: C 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 64 Everyone needs read access to inventory documents. Only the Inventory Managers group should be able to create inventory documents. The Warehouse group must be able to edit 

these documents. 

How should Claude configure the security? 

A. Set Default read to "All readers and above" on the Security tab of the form properties. Add a computed Authors field to the form with the formula "Inventory Manager". Add a computed Editors field to the formwith the "Warehouse" formula. 
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B. Do not use a Readers field. On the Security tab of the form Properties, decelect "All authors and above" under "Who can create documents with this form", and select "Inventory Managers". Add an "InventoryEditor" role to the 

ACL.Associate the role with the Inventory Managers group and the Warehouse group.Add a computed Authors field on the form with the "[InventoryEditor]" formula. 

C. Add a computed Readers field with the "Default" formula. On the Security tab of the form Properties, clear "All authors and above" under "Who can create documents with this form", and select "Inventory Managers". Add an "InvEditor"role 

to the ACL, associate the role with the Inventory Managers group and the Warehouse group, and then create a computed Authors field on the form that contains the "InvEditor" formula. 

D. Add a computed Readers field to the form with the formula "*". Add a computed Authors field to the form that contains the formula "Inventory Managers":"Warehouse". Open the ACL and deselect "Create documents" option for 

theWarehouse group. 

Correct Answer: B 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 65 

Which one of the following formulas does Cheng use to change the value of the ReleaseDate field to today's date? 

A. FIELD ReleaseDate := @Today 

B. SET Releasedate :=@Today 

C. @ChangeField(ReleaseDate;@Today) 

D. ReleaseDate := @Today 

Correct Answer: A 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 66 

Janira is adding a Received date to her Video Rental form. She would like to have the date field show the user a calendar for date selection. 

How would she accomplish this? 

A. Set the field Type to Calendar 

B. Set the field Style to Notes Calendar control 

C. Set the field Style to Calendar/Time control 

D. Set the field Type to Calendar/Time 

Correct Answer: C 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 67 

James would like to use profile documents to track individual users' preferences when they access his Web site. 

How can he collect the user preference information and create a new profile document? 

A. Have users enter their preferences in a form via the browser and then create the profile document using @Command([SetProfileDocument]) in the WebQuerySave agent. 

B. Have users enter their preferences in a form via the browser and then create the profile document using @Command([SetProfileField]) in the $$Return field. 

C. Create a link to open a profile document using @Command([CreateProfileDocument]) and have users submit the form. 

D. Create an action button on a Web page and use @Command([CreateProfileDocument]). 

Correct Answer: B 
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Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 68 

A system administrator needs to give Web users access to databases on DomServer1/Acme. Presently, only Lotus Notes clients are allowed to access the database using TCP/IP. 

What should the system administrator do? 

A. Add HTTP access to the DomServer1/Acme Domino directory. 

B. Add WebService access to the DomServer1/Acme Domino directory. 

C. Add HTTP to the list of server tasks in the DomServer1/Acme Notes.ini file. 

D. Add WebService to the list of server tasks in the DomServer1/Acme Notes.ini file. 

Correct Answer: C 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 69 

What type of element CANNOT be embedded into a page? 

A. Date picker 

B. View 

C. Editor 

D. Navigator 

Correct Answer: C 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 70 Hassan has been emailed a spreadsheet with information about new training opportunities at his company. He has been asked to update the company's Announcements application with a link that, when clicked, will open 

the spreadsheet. 

How can Hassan accomplish this? 

A. Import the presentation as a new File resource, assigning an alias of “New Training”. Add a new entry to the application outline, selecting Action as the Content Type, and setting the Content Value to @Command([OpenResource]; 
“NewTraining”). 

B. Embed the presentation on a new page, setting the page Auto Launch property to First OLE Object. Add a new entry to the application outline, selecting named Element as the Content Type and selecting the new page as the 
ContentValue. 

C. Attach the presentation on the About application document. Set the database launch property to launch the first attachment in the About database. Add a new entry to the application outline, selecting Action as the Content Type andsetting 
the Content Value to @Command([HelpAboutDatabase]). 

D. Import the presentation as a new Image Resource, retaining the filename extension as part of the resource name. Add a new entry to the application outline, selecting Named Element as the Content Type and selecting the new 

imageresource as the Content Value. 

Correct Answer: B 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 71 
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Susan has deployed a template, "sales.ntf", for the Sales Tracking application on the test server. Fred wants to create a new Sales Tracking application using Susan's template, and Fred wants his new application to inherit future design 

changes from the template. 

How can Fred do this? 

A. Create a replica of the “Sales.ntf” template, but make its file name end in “.nsf” instead. 

B. Create a blank application, right-click the new application icon, and choose the “Cope From Template” option. Select the “sales.ntf” file as the template, then design elements will be copied to the new application. 

C. Select File>Application>New, choose the test server as the template server, and choose the “sales.ntf” template. 

D. Select File>Application>New, choose the test server as the template server, and give the application “sales.ntf” as a file name. 

Correct Answer: C 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 72 

In the past, Lloyd has copied an existing application if he needed to create a new application. This time, however, Lloyd wants to create a new application on his own hard drive, and he does not want the application to include any design 

elements from existing applications. 

How can he do this? 

A. From the menu bar, select File > Application > New. Leave the Server option set to “Local”, and ensure that the Template option is set to “Blank”. 

B. From the menu bar, select File > Application > New. Leave the Server option set to “Local”, and specify “_blank.nsf” for the new application’s filename. 

C. From the menu bar, select File > Application > New. Leave the Server option set to “Local”, and specify “_blank.nsf” for the new application’s filename. Ensure that the Template option is set to “-Default-“. 

D. From the menu bar, select File > Application > New. Specify “_blank.nsf” for the new application’s filename. 

Correct Answer: A 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 73 Joe wants to display a company logo in the background of a view in his 

sales application. 

How can he do this? 

A. Use URL as the background graphic for the view, where the URL points to the logo. 

B. He can’t do this. Views cannot have background graphics. 

C. Use an Image Resource as the background graphic for the view. 

D. Display the view in a frameset, and set the background of the view’s frame to an Image resource or URL depicting the logo. 

Correct Answer: C 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 74 

Tyrone is working on the branding of the company's Registration application, and he needs to add the company logo to each form. 

How can he do this and minimize potential future maintenance if the logo changes? 

A. Add the logo from the Resources – Images area. 

B. Add the logo from the Resources – Style Sheets area. 
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C. Add a computed link to the logo in each form. 

D. Add the logo from the Resources – Files area. 

Correct Answer: A 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 75 

Roberto has been asked to modify the Membership view in the Video Rental application. A green checkmark should appear in the Approved view column for each document where membership has been approved. He set the view column 

property to "Display values as icons", and now he needs to write a column formula. 

What is the column formula he needs to use? 

A. @if(Approved = “Yes”; @Icon(82); @Icon(0)) 

B. @if(Approved = “Yes”; @OpenImageResource(”checkmark.gif”);’’”) 

C. @If(Approved = “Yes”; 82; 0) 

D. @If(Approved = “Yes”; @Column(82); @Column(0)) 

Correct Answer: C 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 76 

Muriel has integrated an outline into her database to provide the navigation, and she has verified that the functionality is correct. Instead of displaying the default folder icons to indicate when an outline entry can be expanded, Muriel would like 

to display a plus sign, similar to what she sees in the Domino Designer interface when looking at the outline of design elements for a database, and similar to what her users see when they open Windows Explorer. 

How can Muriel get the desired appearance for her outline? 

A. Open the Outline Entry properties box for each expanded entry. From the Info tab, select Image and select “OS style”. 

B. Open the outline and from the Outline properties box, select the Styles tab. Select “Three options”. In the options area that now displays, select “Show twisties”, and select “OS style. 

C. Create or locate graphics of the plus sign and the minus sign. Copy these graphics as expand.gif and collapse.gif to the server’s domino\graphics folder, replacing the default icons. 

D. Open the Embedded Outline properties box from the page on which the outline is embedded. 

Correct Answer: D 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 77 

Donna created a full-text index for the PerformanceReview database, and she was careful to select the "Index encrypted fields" option. But the HR managers, who all have the secret key that they use to encrypt the data, have reported that 

their search results are not yielding the expected results. 

What is one possible reason for this? 

A. The “Index encrypted fields” setting applies only to documents added after the full-text index is created or to documents edited and saved after the index is created. 

B. The full-text index was created with an id that did not include an encryption key capable of decrypting fields before indexing. 

C. Encrypted fields can be indexed only from a database replica residing on the administration server as specified on the Advanced tab of the database ACL. Donna had indexed the database on the application server. 

D. The “Index encrypted fields” setting enables the indexing. The next step before creating the index is to designate the specific encrypted fields that are to be indexed. 

Correct Answer: B 

Section: (none) 
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Explanation 

Explanation/Reference: 

QUESTION 78 Which one of the following describes the use of hidden 

column formulas? 

A. View columns can be displayed or hidden based on a formula. 

B. Table columns can be hidden based on a formula. 

C. Views can be hidden based on a formula. 

D. Hidden columns are not a supported feature. 

Correct Answer: A 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 79 

Dora has a view with a column that shows the date and time at which the document was created. She would like to show just the date and hide the time portion. 

How can she accomplish this? 

A. In the Column Properties dialog box, set the column style to Date/Time and format the date to be mm/dd/yyyy. 

B. In the view Properties dialog box, set the view style to Date/Time, and deselect the Display Time option. 

C. In the Column Properties dialog box, set the column style to Date/Time and deselect the Display Time option. 

D. In the view Properties dialog box, set the view style to Date/Time, and format the date to be mm/dd/yyyy. 

Correct Answer: C 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 80 

Olga wants to have one action on the Video form that will give the options to Print, Save, and Exit the document when it is clicked. 

In which one of the following ways can she accomplish this? 

A. Use action buttons within an Outline control in a hidden frame to present “twisties”. 

B. Layer the actions in the Action menu. 

C. Use Hide/when formulas along with a database profile field setting to display “toolbars” of icons. 

D. Create a parent action with programmable subactions. 

Correct Answer: D 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 81 Carmen created two new roles in the ACL of her database, naming one role "DbAdmin" and the other role "SalesManager". She now wants to add a computed Authors field to the SalesOrder form to include both 

of these roles. 

What should Carmen enter in the value formula for this field? 
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A. “DbAdmin”:”SalesManager” 

B. @Authors(“DbAdmin”:”SalesManager”) 

C. @Authors(“[DbAdmin]”:”[SalesManager]”) 

D. “[DbAdmin]”:”[SalesManager]” 

Correct Answer: D 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 82 

Susan has deployed a template, "sales.ntf", for the Sales Tracking application on the test server. Fred wants to create a new Sales Tracking application using Susan's template, and Fred wants his new application to inherit future design 

changes from the template. 

How can Fred do this? 

A. Create a blank application, right-click the new application icon, and choose the “Copy From Template” option. Select the “sales.ntf” file as the template, and the design elements will be copied to the new application. 

B. Crea a replica of the “sales.ntf” template, but make its file name end in “.nsf” instead. 

C. Select File>Application>New, choose the test server as the template server, and choose the “sales.ntf” template. 

D. Select File>Application>New, choose the test server as the template server, and give the application “sales.ntf” as a file name. 

Correct Answer: C 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 83 Malik needs to find all the design elements that reference a particular field 

in his database. 

How could he accomplish this? 

A. Edit – Find Next 

B. Edit – Find/Replace 

C. File – Application – Analyze Design 

D. File – Application – Design Synopsis 

Correct Answer: D 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 84 

Janira is adding a Received date to her Video Rental form. She would like to have the date field show the user a calendar for date selection. 

How would she accomplish this? 

A. Set the field Type to Calendar 

B. Set the field Style to Noted Calendar control 

C. Set the field Type to Calendar/Time 

D. Set the filed Style to Calendar/Time control 

Correct Answer: D 
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Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 85 Web users using Robert's Lotus Domino-based site are able to submit 

formatted text. 

How does he accomplish this task on his form? 

A. Display a rich text field within an HTML text area. 

B. Display a text field as an editor applet. 

C. Display a rich text field as an editor applet. 

D. Display a rich text lite field within an HTML text area. 

Correct Answer: C 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 86 Parker is examining a WSDL file for his Lotus 

Domino Web service. 

What role does the Types element have in the file? 

A. It defines the browser client types that can support the Web service. 

B. It defines the data types used in the Web service. 

C. It defines the types of access allowed by the Web service. 

D. It defines the method types returned by the Web service. 

Correct Answer: B 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 87 

Sara's application needs to use the same graphic in several forms. When she designed the application, she pasted the graphic into each form. However, when she views documents that were created with these forms, the browser reacts very 

slowly. 

What should Sara do to correct this problem? 

A. Remove the graphics from the forms. 

B. Convert the graphic format to a TIFF and paste it back into the forms. 

C. Place the graphic in the database as an image resource and reference the image resource in all related forms. 

D. Place the graphic file on the server in the graphics directory and use pass-through HTML to reference the graphic. 

Correct Answer: C 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 88 
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Dierdre is periodically asked to update the Readers field in documents created with the SalesOrder form. If a person's name changes, they are no longer able to access documents they'd been able to access in the past. Dierdre would like the 

Readers fields to be automatically updated when someone's name has been changed in the Domino directory. 

How can she do this? 

A. Open the Security tab of the Database properties. In the selection list for Administration Actions, choose “Update all Readers and Authors fields”. 

B. Open the Advanced tab of the Database ACL. In the selection list for Actions, choose “Modify all Readers and Authors fields”. 

C. Ask a Notes Administrator to enable “Maintain Reader/Author field consistency” on the Security tab of the server. 

D. Ask a Notes Administrator to enable “maintain reader/Author field consistency” on the Security tab of the server. 

E. Open the Security tab of the SalesOrder Form properties. Place a checkmark next to “Enable adminp updates”. 

Correct Answer: B 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 89 Which of the following statements regarding cascading stylesheets (CSS) in Lotus Domino 

Designer is true? 

A. The cascading stylesheets can be turned into shared resources. 

B. Cascading stylesheets can be edited within Lotus Domino Designer. 

C. Cascading stylesheets can have an .html file extension. 

D. They only control font and color properties. 

Correct Answer: A 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 90 Susan wants to populate a field in the Inventory form so that when a user composes a document they can select from a dialog 

list of products. 

Which @function can she use to look up to an Inventory view within the same database? 

A. @DbLookup 

B. @DbTitle 

C. @DbColumn 

D. @DbName 

Correct Answer: C 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 91 Maggie wants to display the authenticated user's name on her Web site's 

welcome page. 

How can she do this? 

A. Write a JavaScript function that gets the name from the session cookie. 

B. None of the Above 

C. Use the JavaScript document.userName property. 
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D. Create computed text on the page that computes to the current user’s name. 

E. Display the name using the USER_NAME CGI field. 

Correct Answer: D 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 92 Sam is creating an agent that runs as a WebQueryOpen agent on 

her Web form. 

What agent target should she select on her agent's properties to make sure that the agent runs properly? 

A. All Documents in the Database 

B. None 

C. Current Document 

D. All New and Modified Documents 

Correct Answer: B 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 93 Which one of the following statements about controlled-access 

sections is TRUE? 

A. When a signed field appears in a controlled-access section, the signature applies to the entire document. 

B. A controlled-access section can be used in several forms by placing it on a subform. 

C. Multiple controlled-access sections can appear on one form, but only one section can include a signed field. 

D. Multiple controlled-access sections cannot appear on one form. 

Correct Answer: B 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 94 

John is working in the Eclipse workspace. Which view will display errors, warnings, and other information about IBM Lotus Domino Designer resources? 

A. Events view 

B. Problems view 

C. Properties view 

D. Outline view 

Correct Answer: B 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 95 Logan has a servlet that he wants to deploy as part of his Lotus Domino-based 

Web application. 
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What does he need to do to accomplish this task? 
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Correct Answer: 

Section: (none) 
Explanation 

Explanation/Reference: 

 

A. Deploy the server to a J2EE application server. 

B. Enable servlet support for the Lotus Domino server by modifying the Java Servlet Support section of the server document. 

C. Create a Web configuration settings document and change the Configuration Type to “Servlet Support”. 

D. Lotus Domino does not support the use of servlets. 

Correct Answer: B 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 96 

Ted is in a group that has Author access in the Review application's ACL. However, he cannot edit a review he created. 

Which one of the following is the most likely reason? 

A. He must have Editor or higher access to modify documents. 

B. The developer neglected to select the “modify documents” option in the ACL. 

C. Authors can only create documents. 

D. The developer neglected to include an Authors field to the Review form. 

Correct Answer: D 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 97 

Ken would like to allow remote salespeople to replicate information from the videoinfo.nsf application to their laptops, so that the replications are fast and the application on each laptop isn't too big. Each salesperson should only replicate the 

information from their territory. 

Which one of the following does Ken need to do to configure this? 

A. Use AuthorName fields to limit access to information. 

B. Use a selective replication formula. 

C. Give the salespeople reader access to the application. 

D. Give the SalesPeople group the [TerritiryOnly] role 

Correct Answer: B 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 98 

Henry has an executable file stored as a file resource in his database. He wants to make this file available for use via a Web browser, using the URL syntax: http://server/db.nsf/filename?OpenFileResource. 

What additional things does he need to do? 

A. He needs to enable the “Use File Resources on the Web” database property. 

B. He needs to update the MIME type property in the File Resource properties field to “application/executable”. 

C. He doesn’t need to do anything else. The file will be available to users as is. 
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D. 

An executable file cannot be made available to Web browsers as a file resource. 

C 

QUESTION 99 Jack cannot get two buttons on his Web form to display when using 

a Web browser. 

What is the most likely cause of this problem? 

A. The form property “Web Access: Show buttons” must be selected. 

B. Only the Submit button displays for Web clients. 

C. Multiple buttons on a form must be coded using JavaScript. 

D. The database preference “Web access: use JavaScript when generating pages” is not selected. 

Correct Answer: D 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 100 Melissa has created a default outline in her application and wants to display specific outline 

entries to Web users. 

How can she do this task? 

A. Select or clear the “Hide entry from Web browsers” check box for the Outline entry. 

B. Use Hide-when formulas on the page where the outline is embedded. 

C. Surround outline entries with HTML tags to make them visible to Web users. 

D. Create a separate outline for Web users. 

Correct Answer: A 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 101 Which one of the following can Monique include in a workflow application to allow users to manually forward 

documents to others? 

A. An action containing @DocForward 

B. An action containing @MailSend([Forward]) 

C. An action containing @Command([MailForward]) 

D. An action containing @MailSend, and a Forward To Field 

Correct Answer: C 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 102 
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Correct Answer: 

Section: (none) 
Explanation 

Explanation/Reference: 

 

Pedro created a document in the Suggestion application. After saving and closing the document, he was unable to see his document or any other documents in the main view. 

What level of access does Pedro have in the Suggestion application? 

A. Author 

B. No Access 

C. Depositor 

D. Anonymous 

Correct Answer: C 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 103 

Robert is adding an editable field called CountryLocation to the Member form in the Video Rental application. The field should show a value of USA when the document is first created. 

What formula would accomplish this behavior? 

A. “USA” in the field’s Input Translation object 

B. “USA” in the field’s Input Enabled object 

C. “USA” in the field’s Default Value object 

D. “USA” in the field’s Input Validation object 

Correct Answer: C 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 104 

Hans and Kristen, two mobile users, are editing different fields in the same document during a parallel review. The designer set a form property to merge replication conflicts. 

Which one of the following will happen? 

A. Edits to both fields will be saved in two identical main documents. 

B. Edits to both fields will be saved in a single document marked as a replication conflict. 

C. Edits to each field will be saved in two documents: one a main document and the other a response document marked as a replication conflict. 

D. Edits to each field will be saved in a single document. 

Correct Answer: D 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 105 Management has asked Bob to post an introductory Welcome page when Notes users first open the 

Video application. 

In which one of the following places should Bob put the Welcome message? 

A. In the application About Document 
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D. 

B. In the first Page in the application designC. In a document named $Welcome In the application Using Document 

A 

QUESTION 106 

Amanda is creating a response document in a CRM database, and she wants to inherit some information into the new document. 

Which setting would allow her to do this? 

A. Select the “Formulas inherit values from selected document” in the “On Create” section of the Document properties. 

B. Select the “Formulas inherit values from selected document” in the “On Open” section of the Document properties. 

C. Select the “Formulas inherit values from selected document” in the “On Create event of the document. 

D. Select the “Formulas inherit values from selected document” in the “On Open” event of the document. 

Correct Answer: A 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 107 

When the Print statement is used in a Web agent, such as WebQuerySave, what does the Print statement do? 

A. Output from all Print statements is sent to the browser’s status bar. 

B. Output from all Print statements is sent to the server log. 

C. Nothing. The Print statement is ignored in Web agents. 

D. Output from all Print statements is sent to the browser for display. 

Correct Answer: D 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 108 

Joe wants to store JavaScript code in his forms so that the code can be called from other events on the form. 

Where should he put the code? 

A. In the form’s onLoad event. 

B. In the form’s HTML Body Attributes event. 

C. In the form’s JS Global Functions event. 

D. In the form’s JS Header event. 

Correct Answer: D 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 109 
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Correct Answer: 

Section: (none) 
Explanation 

Explanation/Reference: 

 

The XYZ Company has offices in many different countries. There is a single Inventory database, replicated to a server in each country. Users connect to the server associated with the country in which they work. Each product document 

includes a multivalued field named Country, indicating the country or countries in which the product is available. 

How can Drew ensure that the server at each country is sent only the data for products available for sale within that country? 

A. From the Security tab of the properties on each country’s replica database, select “Restricted replication”. Select “Restrict by formula”. Enter a replication formula of: SELECT @IsMember(“COUNTRY_NAME”; Country). 

B. Add a computed Authors field to the Product forms in the database. use a value formula of “Country”. Run an agent to refresh all documents. 

C. From the Advanced tab of the replication settings for each country’s replica database, select “Documents by selection formula”, and enter the formula: SELECT @IsMember(“COUTRY_NAME”; Country). 

Correct Answer: C 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 110 

Anika has been told that users cannot use the embedded view on a form because it is too wide. On Anika's screen setting for 1920 resolution, the form uses only 25 percent of her screen. 

What can Anika do to allow users to use the full width of their screen, regardless of their resolution, while using an embedded view? 

A. Anika can set the Form properties to use only 85 percent of the screen width. 

B. Anika can set the Display properties of the embedded view to use only 85 percent of the screen width. 

C. Anika can set the text properties of the form to 85 percent of the screen width. 

D. Anika can set the Display options for the embedded view to “fit to window”. 

Correct Answer: B 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 111 

Serge wants to store some user preferences in a database so that users can set custom settings and have those settings available the next time they use the database. 

What kind of special Lotus Notes design element should he use? 

A. Preference form 

B. Profile document 

C. Settings document 

D. User form 

Correct Answer: B 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 112 

When Eduardo tried to save a document, he got the following error message: Incorrect data type for operator or @Function: Text Expected. 

Which one of the following did he most likely do to cause this to happen? 
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D. 

A. He combined a text and a time field in a formula. 

B. He neglected to place a formula in a validation event. 

C. He neglected to place a formula in a translation event. 

He entered text in a number field. 

A 

QUESTION 113 Which one of the following formulas would find the first word (all characters before the first space) in a string 

field called Name? 

A. @Left(Name) 

B. @Left(Name;1) 

C. @Left(“ “;Name) 

D. @Left(Name; “ “) 

Correct Answer: D 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 114 Review the formula below, assuming that the Author field 

contains the following: 

Richard Clarke/Meadowlands/ACME @Left(@Name([CN]; Author);" ") 

Which one of the following will the formula produce? (Note: The substring portion of the @Left statement contains a single space.) 

A. Richard Clarke 

B. Richard 

C. Clarke 

D. Meadowlands 

Correct Answer: B 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 115 

The Video application ACL supports 3 types of users: 

1. Users who can only view information in the application. 

2. Users who can view, enter, and edit the information they have entered in the application. 3. Users who can view and modify any document in the application. 

Cyd created groups in the Directory to hold the names of the different user types: 

1. Video Viewers 

2. Video Creators 

3. Video Modifiers Cyd adds the three groups and wants to control the access of different users. 

In which one of the following ways should he assign access levels? 

A. 1. Video Viewers = Reader 
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Correct Answer: 

Section: (none) 
Explanation 

Explanation/Reference: 

 

2. Video Creators = Author 

3. Video Modifiers = Editor 

B. 1. Video Viewers = Readers 

2. Video Creators = Depositor 

3. Video Modifiers = Designer 
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C. 1. Video Viewers = Reader 

2. Video Creators = Editor 

3. Video Modifiers = Editor 

D. 1. Video Viewers = Reader 

2. Video Creators = Editor 

3. Video Modifiers = Manager 

Correct Answer: A 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 116 

Several users have been calling to report that they cannot print documents from the Sales Reports database. They all have Editor access to the database and can read and edit all documents, but the File > Print option and the Print icon are 

grayed out. 

What could be the problem? 

A. The document are encrypted. Encrypted documents can be viewed and edited by users with the correct key, but these documents cannot be printed. 

B. The database ACL option “Replicate or copy documents” has been selected to prevent the creation of local replicas. This setting also prevents printing of the documents from the within the database. 

C. The “Disable printing/forwarding/copying to clipboard” option has been selected on the Security tab of the Database properties. 

D. The “Disable Field Exchange” option has been selected from the Info tab of the Form properties. This option prevents data from being exchanged with other applications and sending the data to the printer. 

Correct Answer: B 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 117 

Jason coded and saved a scheduled Java server agent that should execute on ServerX. The agent does not run at all, even though Jason signed it with his Notes id. 

Given that the agent manager is running on the server, which one of the following should Jason check first to diagnose the problem? 

A. Check whether Jason is in the “Database administrators” list on the server document. 

B. Check the Agent security tab to make sure that “Run as web user” is selected. 

C. Check whether an anonymous user is allowed to run agents on the server. 

D. Check whether Jason is in either the “restricted” or “unrestricted” agents list on the server. 

Correct Answer: D 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 118 

Wesley is able to see documents in the Suggestion application that have his name listed in the "SuggestionContact" field. He cannot see any other documents nor can he edit the documents he can see. 

What level of access does Wesley have in the ACL for this application? 

A. Author 

B. Reader 

C. Depositor 
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D. Editor 

Correct Answer: B 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 119 Which one of the following statements about an 

Authors field is true? 

A. Groups can be used. If individual names are used, they must be stored in Abbreviated format. 

B. Groups and roles can be used. Individual names should be stored in Abbreviated format if the application will be used in multiple domains. 

C. Roles can be used. If individual names are used, they must be stored in Canonical format. 

D. Groups and roles can be used. Individual names should be stored in Canonical format if the application will be used in multiple domains. 

Correct Answer: D 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 120 Bram needs to change a large number of documents in a existing application and add the three fields from the Document NewDoc to each existing document. He has created a document collection of the documents 

to be changed. 

How can he best achieve this? 

A. Call Collection.Stampall (“Location” : “HomeID” : “HelpNr” ; “NY” : “123” : “80012345678”) 

B. Call Collection.StampallMulti (“Location” : “HomeID” : “HelpNr” ; “NY” : “123” : “80012345678”) 

C. Call Collection.StampAllMulti (NewDoc) 

D. Call Collection. Stampall (NewDoc) 

Correct Answer: C 

Section: (none) 

Explanation 

Explanation/Reference: 

QUESTION 121 

When Robert created a Response form, he set the "Formulas inherit values from selected document" option on the form properties. The "Status" field on the Review form is also named "Status" on the inheriting form. However, the form does 

not inherit any data. 

Which one of the following most likely caused this problem? 

A. The inheriting form is not a Response form. 

B. He specified the same field names on both forms. 

C. He failed to provide inheritance formulas for each field. 

D. He failed to specify the form type. 

Correct Answer: C 

Section: (none) 

Explanation 

Explanation/Reference: 
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